Forgot your password?   No account Yet? Register
swMenuPro Logo
Advanced Menu System for Joomla
Board index swMenuPro Forum swMenuPro8.0+ SWmenuPro 8.1 - Trans menu doesn't work (IE11, FF42)

SWmenuPro 8.1 - Trans menu doesn't work (IE11, FF42)

Please post all enquiries regarding swMenuPro8+ to this forum

Galaks Newbie
Newbie

Posts: 4

Hi
Just purchased Pro 8.1 and found out that Trans menu doesn't work in IE11 and FF42. Replaced files as it was recomended in the Forum (2013) with no result. Free 6.1 works at least in FF42, by the way. Please, help to make Pro 8.1 to work - I need more menus for my Joomla 1.5 based site and can't migrate to Joomla 2.5 or 3.0.

Galaks Newbie
Newbie

Posts: 4

Galaks wrote:
Hi
Just purchased Pro 8.1 and found out that Trans menu doesn't work in IE11 and FF42. Replaced files as it was recomended in the Forum (2013) with no result. Free 6.1 works at least in FF42, by the way. Please, help to make Pro 8.1 to work - I need more menus for my Joomla 1.5 based site and can't migrate to Joomla 2.5 or 3.0.


Changed my menu settings and get it work in FF42/43 - sorry, it was my fault. In IE11 Trans menu still doesn't show sub menus ,with or without replacement of files, recommended in april 2013 in this forum.

Galaks Newbie
Newbie

Posts: 4

Found out one more problem in my menu: in IE11 background color of visited menu buttons turned to white. Fortunately, got a fix at http://stackoverflow.com/questions/2954 ... -backcolor in a cooment by Pangloss: ...can you make sure to set all of the 4 states, and in this order? a:link {} a:visited {} a:hover {} a:active{}... So changed my external menu.css file by adding/replacing a few lines:

#menu95 a:link,
#menu95 a.link {
color: #B0FFFF !important ;
background-color: #105272 /*initial bckgr color of top menu button*/ !important ;
}

#menu95 a:visited,
#menu95 a.visited {
color: #B0FFFF !important ;
background-color: #105272 /*bckgr color of visited top menu button*/ !important ;
}

#menu95 a:hover,
#menu95 a.hover {
color: #B0FFFF !important ;
background-color: #0A81B0 /*hover color of top menu button*/ !important ;
}

#menu95 a:active,
#menu95 a.active {
color: #B0FFFF !important ;
background-color: #69F /*bckgr color of active top menu button*/ !important ;
}

Galaks Newbie
Newbie

Posts: 4

Well, sub menu problem seems to be solved, too.
Tried to set a compatibility mode for IE by adding a following tag
$strHtml .= $tab.'<meta http-equiv="X-UA-Compatible" content="IE=10"'.$tagEnd.$lnEnd;
right above the tag
$strHtml .= $tab.'<title>'.htmlspecialchars($document->getTitle()).'</title>'.$lnEnd;
in /libraries/joomla/document/html/renderer/head.php

Now my site opens in IE11 as in IE10 and sub menus are showing just as in other browsers.

Guess, the way, I've added my code is not perfect, so, any professional coder is welcome to suggest a better way to set a compatibility mode for IE :)


Return to swMenuPro8.0+

cron